2
Vote

Add support for new EDMX versions/xls namespaces

description

You get a really nasty errors when you try to use this lib with the new / upgraded edmx file.:

at Xml.Schema.Linq.XTypedServices.ToXTypedElement(XElement xe, ILinqToXsdTypeManager typeManager, Type rootType, Type contentType)
at Xml.Schema.Linq.XTypedServices.ToXTypedElement[W,T](XElement xe, ILinqToXsdTypeManager typeManager)
at Xml.Schema.Linq.XTypedServices.Load[W,T](String uri, ILinqToXsdTypeManager typeManager)
at LinqToEdmx.Edmx.Load(Edmx edmx, String splitPath)
at System.Linq.Enumerable.Aggregate[TSource,TAccumulate](IEnumerable1 source, TAccumulate seed, Func3 func)
at LinqToEdmx.Edmx.Load(String path)

It would be greatly appreciated if the library was updated to support the new runtime version.

https://entityframework.codeplex.com/workitem/1265
https://entityframework.codeplex.com/workitem/1337

comments

blake05 wrote May 23, 2014 at 10:56 AM

Have you had a chance to take a look into this?